Issues with Cisco 1900 series Router and Sonicwall TZ series with MPLS

Recently our local ISP Charter Communications rolled out an MPLS product they’ve dubbed Ethernet over Coax (EOC).  It’s a great low cost product that creates a Layer 2 connection between two sites.  Very similar to their point to point Fiber solutions.  Currently the physical install consists of a coax connection to a Cisco Cable modem connected via ethernet to a Cisco 1900 series router.  The Cisco router exposes 3 fast Ethernet ports in a WIC interface for customer use.  The theory is that you can connect any device to these ports with the IP information of our choosing and the solution will seamlessly pass the traffic to the remote site.  During a recent installation using a Sonicwall TZ210 as the customer perimeter device we failed to get any sort of connectivity.  We went so far as to verify our configuration with Sonicwall support and the ISP NOC.  NOC engineers informed us that there wasn’t so much of a byte of traffic hitting their interface meanwhile we showed traffic in our Sonicwall doing it’s best to transmit.  We suspected a hardware issue.  After much troubleshooting the key turned out to be the Link settings on the Sonicwall interface.  It turns out Charter configures their Cisco 1900 by hard coding their interface at 100Mbps/Full Duplex.  Our Sonicwall incorrectly auto-detected the link as a 100Mbps/half duplex.  To make matters worse this had the result of causing arp traffic to fail to the Cisco interface.  Adjusting the setting to a fixed state on the Sonicwall instantly corrected the traffic flow.  For those of you who wish to take your hand at this setup you can see a walk-through after the break.

Click to continue reading “Issues with Cisco 1900 series Router and Sonicwall TZ series with MPLS”